DLL module not found

I have tried installing OpenCV both manually and through Conda install,
The thing is that every steps work fine for me on my laptop, but the same steps say DLL module not found on my workstation, I find it very strange,

Also I have faced the same issue when working on Android Studio with Opencv, the library is there in the right path, and shows on the directory and shows successful import as well but on running my codes, i get the message OpenCV not does not exist,

I thought it might be due to the path or due to wrong labelling or even due to version imcompatibility but heyy how come the same things work fine on my laptop,

I never had any issues with any library before, and I am having open internet, no firewalls blocking access and my workstation is very high capacity…I do not understand the issue at all…

always put full error message (starting at word “Traceback”) in question (not comment) as text (not screenshot, not link to external portal). There are other useful information.

Is you workstation using also Windows? Did you install it with pip or copy all code from one computer to another? Different CPU may need different compilation. And if workstation use Linux then DLL may not work.

But without full error message it hard to say what is the problem.

yes both my workstation and laptop are using same windows 10, and i did the opencv by install in both cases, same steps, not copy and paste it works on laptop, but says DLL module not found on workstation, when in fact the library in right there on the path installed. I tried uninstall, then restart then install back, again same error message, and funniest thing is that it is having same issue on every workstation in the lab(although we do have open internet ,no restrictions), I was wondering whether this is due to an internal setting(in the BIOS or…i dont know) …i never had any issue in the past with other library…I will post the full error message asap…

You may have the same Window 10 but

  • one system 32bit, other system 64bit
  • with different updates
  • with different settings - especially environment setting PATH
  • with different Python versions or 32bit and 64bit versions
    (32bit Python will not work with 64bit library)
  • with second DLL in other place on local system and local system may use this second DLL and computers on Lab may not have it. (here problem can make PATH)

Sometimes it may be simpler to use Docker to create virtual machine with all code and copy it on other machines.

But without full error message it is hard to say where is the problem.
Frankly, without full error message this question is only waste of time.

BTW: sometimes Python modules has problem to put DLL in correct place (in Python folder) and then Python can’t find them. And then you have to manually copy this module. Or it may search module with name some-library.dll but it may put some-library-version-1.2.3-for-windows.dll and this can make problem.

BTW: you should copy last part of error message (with DLL) to Google to check if someone else had this problem - maybe someone already resolved this problem long time ago.