Error compile opencv 4.0.0

Hi all! I got an error when compiling OpenCV 4.0.0, I tried compiling with both ‘make’ and ‘make -j1’ and ‘make -j4’
Nothing helped, I’ll attach the error code below

[  7%] Built target libwebp
[ 11%] Built target IlmImf
[ 15%] Built target libprotobuf
[ 15%] Built target quirc
[ 16%] Building CXX object 3rdparty/carotene/hal/carotene/CMakeFiles/carotene_objs.dir/src/absdiff.cpp.o
c++: error: unrecognized command-line option ‘--param=ipcp-unit-growth=100000’; did you mean ‘--param=ipa-cp-unit-growth=’?
make[2]: *** [3rdparty/carotene/hal/carotene/CMakeFiles/carotene_objs.dir/build.make:82: 3rdparty/carotene/hal/carotene/CMakeFiles/carotene_objs.dir/src/absdiff.cpp.o] Ошибка 1
make[1]: *** [CMakeFiles/Makefile2:3622: 3rdparty/carotene/hal/carotene/CMakeFiles/carotene_objs.dir/all] Ошибка 2
make: *** [Makefile:182: all] Ошибка 2

far too old.

problems might be solved in current 4.8.0, so please try with recent branch

also, what kind of os / hardware are you trying to build for ?
(idk of any python platform, which needs/supports carotene)

i use raspi 3b on raspberry pi os, i go try this

1 Like

Wow! it looks like I solved it, I went through this place with an error, before 16% was just an error