Floating point error when running mask_rcnn example code from learnopencv C++

Hi All:

I compiled and installed opencv into a local directory, using the Ubuntu 18.04 installation script…


I compiled the example C++ code from here successfully.

When I run I get floating point errors shortly after a QT window pops up.

./learnopencv/Mask-RCNN/build$ ./mask_rcnn --image=…/cars.jpg

qt5ct: using qt5ct plugin
Floating point exception (core dumped)

I’m not sure how to solve this problem.

please explain what is “the Ubuntu 18.04 installation script”

you likely followed instructions that are outdated or flawed.

further, use a debugger to determine where in your code this issue happens.


I used this script.

This is the first use of openCV in C++ after install. Is there a way to see if my opencv installation is sane for deep learning before trying the example code?

After some debugging I learned that there was a problem with inputs related to color.txt that I resolved.
Thanks! You can close this as solved.