OpenCV IOS Testflight upload


I’ve been try to using OpenCV for quite some time now. Submitting builds to App Store
Maybe due to Xcode 12? The iOS app builds and runs correctly on device, but if I try uploading to App Store connect I get a whole range of errors.

App Store Connect Operation Error
ERROR ITMS-90035: "Invalid Signature. Code object is not signed at all. The file at path [Frameworks/opencv2.framework/opencv2] is not properly signed. Make sure you have signed your application with a distribution certificate, not an ad hoc certificate or a development certificate. Verify that the code signing settings in Xcode are correct at the target level (which override any values at the project level). Additionally, make sure the bundle you are uploading was built using a Release target in Xcode, not a Simulator target. If you are certain your code signing settings are correct, choose "Clean All" in Xcode, delete the "build" directory in the Finder, and rebuild your release target. For more information, please consult 

App Store Connect Operation Error
ERROR ITMS-90081: "This bundle is invalid. Applications built for more than one architecture require an iOS Deployment Target of 3.0 or later."

App Store Connect Operation Error
ERROR ITMS-90087: "Unsupported Architectures. The executable for Frameworks/opencv2.framework contains unsupported architectures '[x86_64, i386]'."

App Store Connect Operation Error
ERROR ITMS-90171: "Invalid Bundle Structure - The binary file 'Frameworks/opencv2.framework/Versions/A/opencv2' is not permitted. Your app can’t contain standalone executables or libraries, other than a valid CFBundleExecutable of supported bundles. Refer to the Bundle Programming Guide at for information on the iOS app bundle structure."

App Store Connect Operation Error
ERROR ITMS-90360: "Missing Info.plist value. A value for the key 'MinimumOSVersion' in bundle Frameworks/opencv2.framework is required."

I have now tested every build of openCV. The one that you get on the download page or any via cmake. But no matter how I integrate it, I cannot upload it to Testflight. Or I can upload some, but then the opencv framework is not uploaded.

can you explain that? what did you do? what did you change?

if this worked before, it’s not OpenCV’s doing.

I would suggest asking that in some Apple support forum since you suspect that it’s got to do with an update to XCode.

we assume that the ws has not worked before because that came from a colleague. I simply imported the opencv2.framework into xcode & selected embet & sign. then these errors come when I want to archive it. everything works locally.