Opencv IP camera lag and delay problem

Hi everyone,

New member on this forum. I have a problem. I’ve written a license plate recognition system program. I’m running the code with Jetson Nano. When I use a local USB webcam, I don’t observe any freezing or lag in the video, and the license plate recognition works. However, when I try to capture video from a 4k MP IP bullet camera from Hikvision, the video opens with the imshow command, but there is a significant lag and delay, almost more than 30 seconds. Additionally, the video freezes a lot during playback. I tried to reduce the resolution using video.capture.set, but it didn’t work well. I need smooth video for plate recognition. Can you help me find a solution? İf you want I can share my code.

it’s always the same procedure: debug it.

test the streaming with something that isn’t opencv. try gstreamer CLI or ffmpeg CLI. what happens?

I will try other solutions. I’ve tried many things but couldn’t get a healthy result.

Hello, I’ve conducted some tests and tried different methods. When I use a USB Webcam, I don’t experience any stream loss; everything is smooth. However, when I try to capture video from an IP camera, unfortunately, the frames pile up. Initially, there is a 10-second delay, but after a while, it increases to 30 seconds. Because of this, I can’t perform license plate recognition. I’ve tried the Gstreamer solution you mentioned, but when I try to install it with pip on the Jetson Nano, I encounter an error. I’ve tried various methods, but I couldn’t install it. Can you assist me? Do I need to change the camera? If you have any lower-resolution cameras to recommend, I can use those as well.

As @crackwitz said this sounds like the standard problem everyone faces when they switch to rtsp. That is you are not requesting your frames fast enough.

To confirm this try

  1. reducing the resolution inside of the Hickvision web interface, not through video capture and
  2. reducing the frame rate (try 1 fps if possible) again inside the Hickvision web interface.

Thank you for the feedback. I will test it and provide information.

Thank you for your support. I have resolved the issue. After changing the settings in the main stream, I started to receive a smooth image.

1 Like

I’m also having the same error as you, can you share with me details on how to handle it?