Opencv path and fatal error: 'opencv2/opencv.hpp file not found

0

I am getting fatal error: 'opencv2/opencv.hpp file not found when I run the make command when trying to install gst-plugins-vr.

I am trying to install gst-plugins-vr according to the following article: How to make VR180 videos from stereoscopic clips | by Youichi Fujimoto | Medium

I have macOS Catalina version 10.15.7 installed.

Someone suggested that the include folder was not added correctly. What folder should I include, and how can I include it?

I’ve tried to two things:

(1) updated the .bash-profile file with export PATH=/usr/local/Cellar/opencv/4.5.1_3/include/opencv4/opencv2:$PATH

(2) updated the $PATH variable in the terminal. Now when I type echo $PATH into the terminal it returns '/usr/local/Cellar/opencv/4.5.1_3/include/opencv4/opencv2:/usr/local/bin:/Users//.pyenv/shims:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/Applications/VMware Fusion.app/Contents/Public"

So far, When I run the make command, I am getting the following errors (I’ve included the terminal output as images).