Need help, Kernel32.lib missing

Hi, i followed this video to install and link opencv 4.5.3 : LEARN OPENCV C++ in 4 HOURS | Including 3x Projects | Computer Vision - YouTube. However when i try to start, it fail with an error : lnk1104-cannot-open-file-kernel32-lib. From what i researched some people fixed it by updating or downgrading their windows sdk. I tried several versions. I checked and the file is where it should and my linker setting points to it.

Am i missing something ? Can anyone help me please ?

how on earth did you manage that?

this is the first time I’ve seen anyone have that kind of issue.

anyway, you should really be using cmake to generate VS projects. don’t make your life harder, especially not when you’re new to this stuff.

^^ Thanks for your anwer.
I tried before to make the lib for mngw with cmake but it didn’t workout .
I thought that a premade one would be easier so that why i tried the premade vs15 ones.
I will go back a retry to use cmake for both mingw and vs.
I will probably reinstalll vs2019 totally too.
In the mean time i found a premade 4.5.2 for mingw so i can still follow tutorials.