EigenFaceRecognizer not found yet Extra module 'face' seems to be working

Having some issues getting EigenFaceRecognizer being defined. It doesn’t make much sense to me as when I include the face module, any definitions that come from that seem to be found. One sign to a possible issue is I have to include the entire path to the face.hpp, rather than just #include “opencv2/face.hpp”. Also, I used a tutorial from 2015, and while as long as I updated for my versions, it seemed to work. However, maybe there is something new I am missing. Here is a link to the tutorial I followed.

Any suggestions for why this may be happening? But basically it seems that files within the src folder of the face module are not being found. In fact, relooking at it, some of the files from the src folder are missing from the include/opencv2 folder in the face module… could it be as simple as moving the needed file to that folder? Or would I need to completing rebuild?

first, try to get the sample running

the src folder wont be copied during installation, only the include (and the binary libs)

you have to adjust your “Additional Include Folders” for your project in your ide
so it points to opencv/install/include
do you get any errors ? please show us !

Okay so my properties were already updated. But I double checked that the additional include directory was being pointed to. i.e. ‘C:/Users/rknig/opencv-3.0/build/install/include’

Along with making sure the additional library directories and additional dependencies were updated. ’ $(OPENCV_DIR)/lib’ where OPENCV_DIR = ‘C:\Users\rknig\opencv-3.0\build\install\x64\vc16’

However, #include “opencv2/face.hpp” is still not being found/opened.

Finally, when I changed the #include to the full path the face.hpp, it is able to find it. However, here is the error codes that come out of it.


please use a more recent release, this is far too old to be useful

take a look, if the opencv2 folder inside that contains face.hpp and a face folder with the other missing headers

seems you have a installation / configuration problem, almost impossible to remote-debug, also given, you try with a very outdated version ;(

yeah the folder is probably misleading, but this is using the newest version of opencv. I just named the folder -3 as that’s how the tutorial I followed named it. The opencv2 folder does contain the face.hpp and the face folder

so, that at least means - building and installing the opencv libs worked correctly

problem now is your own project, trying to use those